<!DOCTYPE html><html class="no-js" lang="en-CA"
xmlns:fb="http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><title>COVID-19 cases in BC continue to tumble - My Nechako Valley Now</title><link href="//www.google-analytics.com" rel="dns-prefetch"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes"><link rel="shortcut icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="114x114" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="72x72" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><meta property="og:site_name" content="My Nechako Valley Now"><meta property="og:url" content="https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/"/><meta property="og:type" content="article" /><meta property="og:title" content="COVID-19 cases in BC continue to tumble" /><meta property="og:description" content="The Northern Health region has 44 of the 974 new cases of COVID-19 over the last three days. In a statement released ... more &#8250;"><meta property="og:image" content="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="314" /> <script data-ad-client="ca-pub-3985045263764181" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <link rel="stylesheet" id="wp-forecast-css" href="https://www.mynechakovalleynow.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" /> <script>/* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700', 'Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();</script> <meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="COVID-19 cases in BC continue to tumble - My Nechako Valley Now" /><meta property="og:description" content="The Northern Health region has 44 of the 974 new cases of COVID-19 over the last three days. In a statement released ... more &#8250;" /><meta property="og:url" content="https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/" /><meta property="og:site_name" content="My Nechako Valley Now" /><meta property="article:published_time" content="2021-05-24T22:50:42+00:00" /><meta property="article:modified_time" content="2021-05-24T22:50:49+00:00" /><meta property="og:image" content="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="420" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Dione Wearmouth"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="1 minute"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.mynechakovalleynow.com/#website","url":"https://www.mynechakovalleynow.com/","name":"My Nechako Valley Now","description":"","potentialAction":[{"@type":"SearchAction","target":"https://www.mynechakovalleynow.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-CA"},{"@type":"ImageObject","@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/#primaryimage","inLanguage":"en-CA","url":"https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg","width":750,"height":420,"caption":"Provincial Health Officer, Dr. Bonnie Henry (photo by BC Govenrment Flickr)"},{"@type":"WebPage","@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/#webpage","url":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/","name":"COVID-19 cases in BC continue to tumble - My Nechako Valley Now","isPartOf":{"@id":"https://www.mynechakovalleynow.com/#website"},"primaryImageOfPage":{"@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/#primaryimage"},"datePublished":"2021-05-24T22:50:42+00:00","dateModified":"2021-05-24T22:50:49+00:00","author":{"@id":"https://www.mynechakovalleynow.com/#/schema/person/02ca453ff0c3a1e164ccd1509c0d32f1"},"breadcrumb":{"@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/#breadcrumb"},"inLanguage":"en-CA","potentialAction":[{"@type":"ReadAction","target":["https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/"]}]},{"@type":"BreadcrumbList","@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.mynechakovalleynow.com/","url":"https://www.mynechakovalleynow.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/","url":"https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/","name":"COVID-19 cases in BC continue to tumble"}}]},{"@type":"Person","@id":"https://www.mynechakovalleynow.com/#/schema/person/02ca453ff0c3a1e164ccd1509c0d32f1","name":"Dione Wearmouth","image":{"@type":"ImageObject","@id":"https://www.mynechakovalleynow.com/#personlogo","inLanguage":"en-CA","url":"https://www.mynechakovalleynow.com/wp-content/litespeed/avatar/f5f8f4aea5115597d1b2e4e8e3309ca6.jpg","caption":"Dione Wearmouth"}}]}</script> <link rel='dns-prefetch' href='//ras.vistaradio.ca' /><link rel='dns-prefetch' href='//cdn.vistaradio.ca' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="My Nechako Valley Now &raquo; Feed" href="https://www.mynechakovalleynow.com/feed/" /><link rel="alternate" type="text/calendar" title="My Nechako Valley Now &raquo; iCal Feed" href="https://www.mynechakovalleynow.com/community-calendar/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mynechakovalleynow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4f85c9ee8e1c0f7e86b56bef663f3bff"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='tribe-tooltip-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='elusive-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /><link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.mynechakovalleynow.com/wp-includes/css/dist/block-library/style.min.css?ver=4f85c9ee8e1c0f7e86b56bef663f3bff' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-flexslider-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/flexslider/flexslider-custom.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-social-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/social-icons/css/zocial.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-entypo-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/entypo/css/entypo.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-symbol-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/symbol/css/symbol.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-swipebox-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/swipebox/swipebox.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-bootstrap-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/bootstrap/css/bootstrap.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-theme-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/css/theme.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='child-style-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso-child/style.css?ver=4f85c9ee8e1c0f7e86b56bef663f3bff' type='text/css' media='all' /> <script type='text/javascript' src='https://www.mynechakovalleynow.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/61e54.js?0f680' id='jquery-migrate-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/396e8.js?1489f' id='wpf_update-js'></script> <script type='text/javascript' id='instant-search-js-extra'>/*  */
var instant_search = {"blog_url":"https:\/\/www.mynechakovalleynow.com","ajax_url":"https:\/\/www.mynechakovalleynow.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/0b9b3.js?e53ca' id='instant-search-js'></script> <script type='text/javascript' src='https://cdn.vistaradio.ca/js/iframeResizer.js' id='iframeResizer-js'></script> <script type='text/javascript' src='https://cdn.vistaradio.ca/js/imageMapResizer.min.js' id='imageMapResizer-js'></script> <link rel="https://api.w.org/" href="https://www.mynechakovalleynow.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.mynechakovalleynow.com/wp-json/wp/v2/posts/26261" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mynechakovalleynow.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mynechakovalleynow.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.mynechakovalleynow.com/?p=26261' /><link rel="alternate" type="application/json+oembed" href="https://www.mynechakovalleynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.mynechakovalleynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F&#038;format=xml" /><meta property="fb:app_id" content="335982600081119"/><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.mynechakovalleynow.com"><link rel="https://theeventscalendar.com/" href="https://www.mynechakovalleynow.com/wp-json/tribe/events/v1/" /><style id="vw-custom-font" type="text/css"></style><style type="text/css">::selection { color: white; background-color: #3facd6; }
		
		h1 { line-height: 1.1; }
		h2 { line-height: 1.2; }
		h3, h4, h5, h6 { line-height: 1.4; }

		.header-font,
		woocommerce div.product .woocommerce-tabs ul.tabs li, .woocommerce-page div.product .woocommerce-tabs ul.tabs li, .woocommerce #content div.product .woocommerce-tabs ul.tabs li, .woocommerce-page #content div.product .woocommerce-tabs ul.tabs li
		{ font-family: Oswald; font-weight: 700; }
		.header-font-color { color: #333333; }

		.wp-caption p.wp-caption-text {
			color: #333333;
			border-bottom-color: #333333;
		}
		
		.body-font { font-family: Open Sans; font-weight: 400; }

		/* Only header font, No font-weight */
		.mobile-nav,
		.top-nav,
		.comment .author > span, .pingback .author > span, 
		.label, .tagcloud a,
		.woocommerce .product_meta .post-tags a,
		.bbp-topic-tags a,
		.woocommerce div.product span.price, .woocommerce-page div.product span.price, .woocommerce #content div.product span.price, .woocommerce-page #content div.product span.price, .woocommerce div.product p.price, .woocommerce-page div.product p.price, .woocommerce #content div.product p.price, .woocommerce-page #content div.product p.price,
		.main-nav .menu-link { font-family: Oswald; }

		/* Primary Color */
		.primary-bg,
		.label, .tagcloud a,
		.woocommerce nav.woocommerce-pagination ul li span.current, .woocommerce-page nav.woocommerce-pagination ul li span.current, .woocommerce #content nav.woocommerce-pagination ul li span.current, .woocommerce-page #content nav.woocommerce-pagination ul li span.current, .woocommerce nav.woocommerce-pagination ul li a:hover, .woocommerce-page nav.woocommerce-pagination ul li a:hover, .woocommerce #content nav.woocommerce-pagination ul li a:hover, .woocommerce-page #content nav.woocommerce-pagination ul li a:hover, .woocommerce nav.woocommerce-pagination ul li a:focus, .woocommerce-page nav.woocommerce-pagination ul li a:focus, .woocommerce #content nav.woocommerce-pagination ul li a:focus, .woocommerce-page #content nav.woocommerce-pagination ul li a:focus,
		#pagination > span {
			background-color: #3facd6;
		}
		a, .social-share a:hover, .site-social-icons a:hover,
		.bbp-topic-header a:hover,
		.bbp-forum-header a:hover,
		.bbp-reply-header a:hover { color: #3facd6; }
		.button-primary { color: #3facd6; border-color: #3facd6; }
		.primary-border { border-color: #3facd6; }

		/* Top-bar Colors */
		.top-bar {
			background-color: #333333;
			color: #eeeeee;
		}

		#open-mobile-nav, .top-nav  a, .top-bar-right > a {
			color: #eeeeee;
		}

		#open-mobile-nav:hover, .top-nav  a:hover, .top-bar-right > a:hover {
			background-color: #3facd6;
			color: #ffffff;
		}

		.top-nav .menu-item:hover { background-color: #3facd6; }
		.top-nav .menu-item:hover > a { color: #ffffff; }

		/* Header Colors */
		.main-bar {
			background-color: #f9f9f9;
			color: #bbbbbb;
		}

		/* Main Navigation Colors */
		.main-nav-bar {
			background-color: #333333;
		}

		.main-nav-bar, .main-nav > .menu-item > a {
			color: #ffffff;
		}

		.main-nav .menu-item:hover > .menu-link,
		.main-nav > .current-menu-ancestor > a,
		.main-nav > .current-menu-item > a {
			background-color: #3facd6;
			color: #ffffff;
		}

		/* Widgets */
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon { background-color: #3facd6; }
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count { color: #3facd6; }

		.widget_vw_widget_categories a:hover { color: #3facd6; }

		/* Footer Colors */
		#footer {
			background-color: #111111;
		}

		#footer .widget-title {
			color: #3facd6;
		}

		#footer,
		#footer .title,
		#footer .comment-author,
		#footer .social-subscription-count
		{ color: #999999; }

		.copyright {
			background-color: #000000;
		}
		.copyright, .copyright a {
			color: #dddddd;
		}

		/* Custom Styles */</style><style type="text/css" title="dynamic-css" class="options-output">h1, h2, h3, h4, h5, h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:700;color:#333333;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-family:"Open Sans";font-weight:400;font-style:400;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style>
<!--[if lt IE 9]> <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js"></script> <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--> <script data-optimized="1" type="text/javascript" src="https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/28033.js?26088"></script> <script type="text/javascript">jQuery(document).ready(function() {
				jQuery('body').ihavecookies({
						title: 'Accept Cookies & Privacy Policy?',
						message: 'We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. By continuing to use our website you consent to our Cookie and Privacy Policy. ',
						delay: 600,
						expires: 1825,
						link: 'https://www.vistaradio.ca/privacy/',
						//onAccept: function(){
						//		alert('Yay! You clicked the accept button. This is an optional callback function that can be set on accept.');
						//},
						uncheckBoxes: true
				});
		});</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet"><style type="text/css">:root {
				--purple: #3B3646;
				--red: #EE4B5A;
		}
		/* Cookie Dialog */
		#gdpr-cookie-message {
				position: fixed;
				right: 30px;
				bottom: 30px;
				max-width: 375px;
				background-color: var(--purple);
				padding: 20px;
				border-radius: 5px;
				box-shadow: 0 6px 6px rgba(0,0,0,0.25);
				margin-left: 30px;
				font-family: system-ui;
		}
		#gdpr-cookie-message h4 {
				color: var(--red);
				font-family: 'Open Sans', sans-serif;
				font-size: 18px;
				font-weight: 500;
				margin: 0 0 10px;
		}
		#gdpr-cookie-message p {
				color: white;
				font-size: 15px;
				line-height: 1.5em;
		}
		#gdpr-cookie-message p:last-child {
				margin-bottom: 0;
				text-align: right;
		}
		#gdpr-cookie-message a {
				color: var(--red);
				text-decoration: none;
				font-size: 15px;
				padding-bottom: 2px;
				border-bottom: 1px dotted rgba(255,255,255,0.75);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message a:hover {
				color: white;
				border-bottom-color: var(--red);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button {
				border: none;
				background: var(--red);
				color: white;
				font-family: 'Open Sans', sans-serif;
				font-size: 15px;
				padding: 7px;
				border-radius: 3px;
				margin-left: 15px;
				cursor: pointer;
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button:hover {
				background: white;
				color: var(--red);
				transition: all 0.3s ease-in;
		}</style></head><body id="top" class="post-template-default single single-post postid-26261 single-format-standard custom-background tribe-no-js tribe-theme-parent-presso tribe-theme-child-presso-child site-layout-boxed site-disable-post-box-effects"><nav id="mobile-nav-wrapper"></nav><aside class="zone takeover"><ins data-revive-zoneid="118" data-revive-target="_blank" data-revive-id="b07d3d41c82582579069d81820142439"></ins></aside><div style="position: fixed; top:0px; left:0px; z-index: -1; background: url(//ras.vistaradio.ca/dist/avw.php?raszid=247) center top no-repeat; background-size: cover; width: 100%; height:100%;"><a href="//ras.vistaradio.ca/dist/ck.php?n=NID&amp;cb=RANDOM_NUMBER" target="_blank" style="display: block; width: 100%; height: 100%;"></a></div><div id="off-canvas-body-inner"><div id="top-bar" class="top-bar"><div class="container"><div class="row"><div class="col-sm-12">
<span id="weather-ajax"></span><div class="weather-zone"><script data-optimized="1" src= "/bmp-zone-weather.js?v=20201203"></script></div> <script>jQuery.ajax({
		url : "/wp-content/themes/presso-child/vista/weather-ajax.php",
		dataType: "text",
		success : function (data) {
			if (data!="") {
				jQuery("#weather-ajax").html(data);
			}
		}
	});</script> <div id="listen-live-header"><div class="listen-live-station listen-live-link" data-stream="civh" id="hdr-ll-civh"><div class="wrapper"><span><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/icons/play-hdr.png" alt="Listen Live to 95.9 the GOAT"></span>
<span><h3 class="brand-goat">95.9 the GOAT</h3><h4><div class="song-ticker"></div></h4>
</span></div></div> <script>(function($){
    $('document').ready(function() {
        $.ajax({
            url : "/wp-content/themes/presso-child/nowplaying.php?s=CIVH&g=ROCK&l=1&nolist=true&ts="+ Date.now() +"",
               dataType: "text",
               cache: false,
               success : function (data) {
                if (data) {
                    $("#hdr-ll-civh .song-ticker").html(data);
                    $(".time").css('display','none');

                    if ($('#hdr-ll-civh p.artist').textWidth() + $('#hdr-ll-civh .title').textWidth() >= '90') {
                        $('#hdr-ll-civh .song-ticker').addClass('marquee');
                    }
                    //if ($('#hdr-ll-civh .title').textWidth() >= '80') {
                    //  $('#hdr-ll-civh .title').addClass('marquee');
                    //}

                }
            }
        });
    });
})(jQuery);</script> </div></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav"><i class="icon-entypo-menu">menu</i></a>
<a id="open-mobile-nav" class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav" title="Search"></a></div></div></div></div><header class="main-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div id="logo" class="" style="/*display: block; text-align: center; margin-bottom: 1em; width: 100%;*/">
<a href="https://www.mynechakovalleynow.com/" style="white-space: nowrap;">
<span id="mynow-icon"><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/mynow-icon.png" alt="My Nechacko Now" border="0" width="63" height="63" class="logo-original" /></span>
<span id="mynow-logo"><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/comm/mynechakovalleynow.png" alt="My Nechacko Now" border="0" width="100%" height="50" class="logo-original" /></span>
</a></div><div id="station-logo-header" style="/*display: block; text-align: center; width: 100%;*/"><div>
<a href="https://www.mynechakovalleynow.com/95-9-the-goat/">
<img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/station/CIVH.png?201022" alt="95.9 the GOAT" width="" height="" border="0" class="brand-goat" />
</a></div></div></div></div></div></header><div class="main-nav-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/Valley-Country-165380483533130/" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/ValleyCountryAM" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a>									<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div><nav id="main-nav-wrapper"><ul id="menu-main-navigation" class="main-nav list-unstyled"><li id="nav-menu-item-53" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="https://www.mynechakovalleynow.com/news/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-bullhorn" aria-hidden="true"></i><span>News</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-55" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.mynechakovalleynow.com/news/" class="menu-link sub-menu-link"><span>News</span></a></li><li id="nav-menu-item-201" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/news/nechako-valley/" class="menu-link sub-menu-link"><span>Nechako Valley</span></a></li><li id="nav-menu-item-202" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/news/provincial/" class="menu-link sub-menu-link"><span>Provincial</span></a></li><li id="nav-menu-item-14025" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/hartleys-cat-scan/" class="menu-link sub-menu-link"><span><i class="_mi _before fa fa-podcast" aria-hidden="true"></i><span>Hartley&#8217;s Cat Scan Podcast</span></span></a></li><li id="nav-menu-item-56" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/submit-news-tip/" class="menu-link sub-menu-link"><span>Submit News Tip</span></a></li></ul></li><li id="nav-menu-item-2222" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/win/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-smiley" aria-hidden="true"></i><span>Win</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-52" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="/community-calendar/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-calendar" aria-hidden="true"></i><span>Events</span></span></a><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-360" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/" class="menu-link sub-menu-link"><span>View Calendar</span></a></li><li id="nav-menu-item-359" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/community/add" class="menu-link sub-menu-link"><span>Submit Event</span></a></li></ul></li><li id="nav-menu-item-63" class="main-menu-item  menu-item-even menu-item-depth-0 nav-listen-live-link menu-item menu-item-type-custom menu-item-object-custom"><a rel="civh" href="#" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-play-alt" aria-hidden="true"></i><span>Listen Live</span></span></a></li><li id="nav-menu-item-2342" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item-on-air menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.mynechakovalleynow.com/on-air/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-microphone" aria-hidden="true"></i><span>On Air</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-2343" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/on-air/" class="menu-link sub-menu-link"><span>Shows &#038; More</span></a></li><li id="nav-menu-item-2341" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/95-9-the-goat/" class="menu-link sub-menu-link"><span>Talent</span></a></li><li id="nav-menu-item-2340" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/contact-us/" class="menu-link sub-menu-link"><span>Contact Us</span></a></li></ul></li><li id="nav-menu-item-13972" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/local-connections/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-star" aria-hidden="true"></i><span>Local Connections</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-14026" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/hartleys-cat-scan/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-podcast" aria-hidden="true"></i><span>Podcast</span></span></a></li></ul></nav></div></div></div></div><div id="page-wrapper" class="container"><div class="row"><div id="page-content" class="col-sm-7 col-md-8"><article id="post-26261" class="post-26261 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="tags clearfix">
<a class="label " href="https://www.mynechakovalleynow.com/news/" title="View all posts in News" rel="category">News</a></div><h1 class="post-title title title-large entry-title">COVID-19 cases in BC continue to tumble</h1><hr class="hr-thin-bottom"><div class="social-share">
<span class="header-font">SHARE ON:</span><a class="social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F&amp;t=http://COVID-19%20cases%20in%20BC%20continue%20to%20tumble" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="social-twitter" href="https://twitter.com/share?text=COVID-19+cases+in+BC+continue+to+tumble&url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a><a class="social-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F" title="Share on Google+" target="_blank"><i class="icon-social-gplus"></i></a><a class="social-pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F26261%2Fcovid-19-cases-in-bc-continue-to-tumble%2F&amp;media=https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg&amp;description=http://COVID-19%20cases%20in%20BC%20continue%20to%20tumble" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a></div><div class="post-meta header-font">
<img src="https://www.mynechakovalleynow.com/wp-content/litespeed/avatar/f614a30dd3b932ed9e1093a8f2151a92.jpg" width="48" height="48" alt="Avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />			<a class="author-name vcard author" href="https://www.mynechakovalleynow.com/talent/dwearmouth/" title="View all posts by Dione Wearmouth"><span class="fn">Dione Wearmouth</span></a><span class="post-meta-separator">,</span>
<span class="label-staff">staff</span><span class="post-meta-separator"></span>
<a href="https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/" class="post-date updated" title="Permalink to COVID-19 cases in BC continue to tumble" rel="bookmark">Monday May. 24th, 2021</a></div><div class="post-thumbnail-wrapper">
<a class="swipebox" href="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg" title="Permalink to image of COVID-19 cases in BC continue to tumble" rel="bookmark">
<img width="750" height="420" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1.jpg 750w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1-300x168.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/50045335261_3d4964f76e_c-750x420-1-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" />
</a><div class="vw-featured-image-caption-wrapper"><div class="vw-featured-image-caption">
<i class="icon-entypo-camera"></i> Provincial Health Officer, Dr. Bonnie Henry (photo by BC Govenrment Flickr)</div></div></div><div class="post-content clearfix"><p>The Northern Health region has 44 of the 974 new cases of COVID-19 over the last three days.</p><p>In a statement released this afternoon (Monday), provincial health officials reported on three periods: from May 21 to May 22, there were 356 new cases, from May 22 to May 23, there were 325 new cases and in the last 24 hours, there were less than 300 people that tested positive (293).</p><p><span class="css-901oao css-16my406 r-poiln3 r-bcqeeo r-qvutc0">The rolling 7-day average is 383, the lowest since November 3rd. </span></p><p>There are 3,953 active cases of COVID-19 in the province.</p><p>A further 136,603 people who tested positive have recovered.</p><p>Of the active cases, 292 individuals are currently hospitalized, 96 of whom are in intensive care.</p><p>There have been 12 new COVID-19 related deaths, for a total of 1,679 people that have passed away.</p><p>In addition, 2,885,488 doses of Pfizer-BioNTech, Moderna, and AstraZeneca COVID-19 vaccines have been administered to adults 18 and over in B.C., 147,144 of which are second doses.</p><p>Doctor Bonnie Henry, Health Minister Adrian Dix, and Premier John Horgan will announce BC&#8217;s restart plan tomorrow (Tuesday) afternoon.</p><p><a href="https://experience.arcgis.com/experience/a6f23959a8b14bfa989e3cda29297ded">BREAKDOWN: (over 3 days)</a></p><p>Northern Health: +44 (7,599)</p><p>Interior Health: +117 (11,457)</p><p>Fraser Health: +630 (82,004)</p><p>Vancouver Coastal Health: + 157 (33,444)</p><p>Island Health: +25 (4,835)</p><p>BC: +974 (Total 142,347)</p><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="fb-comments-box"><div class="fb-comments" data-href="https://www.mynechakovalleynow.com/26261/covid-19-cases-in-bc-continue-to-tumble/" data-num-posts="5" data-width="100%" data-colorscheme="light"></div></div></div></article><hr class="hr-thin-bottom"><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="post-related section-container clearfix"><h2 class="section-title">Recent Posts</h2><div class="row"><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-26258 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/26258/province-proclaims-anti-racism-awareness-week/" title="Permalink to Province proclaims Anti-Racism Awareness Week" rel="bookmark">Province proclaims Anti-Racism Awareness Week</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/26258/province-proclaims-anti-racism-awareness-week/" class="post-date" title="Permalink to Province proclaims Anti-Racism Awareness Week" rel="bookmark">Sunday May. 23rd, 2021</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/26258/province-proclaims-anti-racism-awareness-week/" title="Permalink to Province proclaims Anti-Racism Awareness Week" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/sign-3422241_1920-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/sign-3422241_1920-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/sign-3422241_1920-360x200.jpg 360w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/sign-3422241_1920-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-26223 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/26223/four-rivers-co-op-donates-10000-to-st-john-hospital-auxiliary-society/" title="Permalink to Four Rivers Co-op donates $10,000 to St. John  Hospital Auxiliary Society" rel="bookmark">Four Rivers Co-op donates $10,000 to St. John  Hospital Auxiliary Society</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/26223/four-rivers-co-op-donates-10000-to-st-john-hospital-auxiliary-society/" class="post-date" title="Permalink to Four Rivers Co-op donates $10,000 to St. John  Hospital Auxiliary Society" rel="bookmark">Sunday May. 23rd, 2021</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/26223/four-rivers-co-op-donates-10000-to-st-john-hospital-auxiliary-society/" title="Permalink to Four Rivers Co-op donates $10,000 to St. John  Hospital Auxiliary Society" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/20210518_104601-1-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/20210518_104601-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/20210518_104601-1-360x200.jpg 360w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/20210518_104601-1-750x420.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm"><article class="post-26253 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/26253/worksafe-bc-launches-annual-cone-zone-campaign-to-support-roadside-workers/" title="Permalink to WorkSafe BC launches annual Cone Zone campaign to support roadside workers" rel="bookmark">WorkSafe BC launches annual Cone Zone campaign to support roadside workers</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/26253/worksafe-bc-launches-annual-cone-zone-campaign-to-support-roadside-workers/" class="post-date" title="Permalink to WorkSafe BC launches annual Cone Zone campaign to support roadside workers" rel="bookmark">Saturday May. 22nd, 2021</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/26253/worksafe-bc-launches-annual-cone-zone-campaign-to-support-roadside-workers/" title="Permalink to WorkSafe BC launches annual Cone Zone campaign to support roadside workers" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/38-ConeZone_ML_20210517_A0A6220-750x420-1-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/38-ConeZone_ML_20210517_A0A6220-750x420-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/38-ConeZone_ML_20210517_A0A6220-750x420-1-300x168.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/38-ConeZone_ML_20210517_A0A6220-750x420-1-360x200.jpg 360w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/38-ConeZone_ML_20210517_A0A6220-750x420-1.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div></div></div></div><aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4"><div class="sidebar-inner"><div id="text-17" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div><div id="vw_widget_post_slider-4" class="widget vw-sidebar-blog widget_vw_widget_post_slider"><h3 class="widget-title"><span class="super-title">Sponsored Articles</span>Local Connections</h3><div class="post-box-list"><div class="flexslider no-control-nav post-slider"><ul class="slides"><li>
<a href="https://www.mynechakovalleynow.com/26194/covid-19-vaccinations/" title="Permalink to COVID-19 Vaccinations" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/05/Northern-Health-COVID19-Vaccinations-LC-Main-Graphic-810x450-1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>COVID-19 Vaccinations</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/25808/the-homes-that-are-prepared-are-the-homes-that-are-left-standing/" title="Permalink to The Homes That Are Prepared Are The Homes That Are Left Standing" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/Fire-Smart-BC-LC-Article-810x450-1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>The Homes That Are Prepared Are The Homes That Are Left Standing</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/25691/in-a-time-of-covid-building-thriving-communities/" title="Permalink to In a Time of COVID: Building Thriving Communities" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/04/BC-Housing-LC-Article-1-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>In a Time of COVID: Building Thriving Communities</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/25233/covid-19-immunization-plan/" title="Permalink to COVID-19 Immunization Plan" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2021/03/Northern-Health-Vaccination-LC-Article-810x450-1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>COVID-19 Immunization Plan</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/24142/plan-your-next-adventure-right-here-in-prince-george/" title="Permalink to Plan Your Next Adventure Right Here in Prince George" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" loading="lazy" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Plan Your Next Adventure Right Here in Prince George</span></h3></div>
</a></li></ul></div></div></div><div id="text-18" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-side v-promotional-carousel"><div class="v-side v-promotional"><ol><li><img src="https://www.mynechakovalleynow.com/wp-content/plugins/vista-addons/img/facebook-contest-like-300x90.gif"></li></ol></div></div></div></div><div id="text-19" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div><div id="text-20" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-tall-side v-promotional-carousel"><div class="v-tall-side v-promotional"><ol><li><a target="_blank" data-stream="civh" class="listen-live-link" rel="noopener"><img src="https://www.mynechakovalleynow.com/wp-content/plugins/vista-addons/img/never-miss-a-beat-300-525-goat.jpg" width="300" height="525"></a></li></ol></div></div></div></div><div id="text-21" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div></div></aside></div></div><footer id="footer"><div id="footer-nav"><div class="container"><div class="row"><div class="col-sm-10"><div class="v-footer-menu"><ul id="menu-footer" class="menu"><li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-67"><a href="https://www.mynechakovalleynow.com/news/">News</a></li><li id="menu-item-2220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2220"><a href="https://www.mynechakovalleynow.com/win/">Win</a></li><li id="menu-item-66" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66"><a href="/community-calendar/">Events</a></li><li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.mynechakovalleynow.com/contact-us/">Contact Us</a></li><li id="menu-item-69" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69"><a href="https://www.mynechakovalleynow.com/advertise-us/">Advertise</a></li><li id="menu-item-2221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2221"><a href="http://www.vistaradio.ca/about/working-at-vista/">Careers</a></li></ul></div><div class="v-policy-menu"><ul id="menu-policy-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/privacy" target="_blank">Privacy Policy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/terms-of-service/" target="_blank">Terms Of Service</a></li></ul></div></div></div></div></div><div class="copyright"><div class="container"><div class="row"><div class="col-sm-6 copyright-left">
<a href="http://www.vistaradio.ca" target="_blank"><img src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/vista-logo-footer.png" width="86" height="30" border="0" alt="Powered by Vista Radio" /></a></div><div class="col-sm-6 copyright-right"><a href="http://radioplayer.vistaradio.ca" target="_blank"><img width="107" height="30" style="width:107px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/rpc-logo-w30.png"></a>
&nbsp;
<a href="https://itunes.apple.com/ca/app/radioplayer-canada/id1204742241" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-itunes1.png"></a>
&nbsp;
<a href="https://play.google.com/store/apps/details?id=ca.radioplayer.android" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-play1.png"></a></div></div></div></div></footer></div>  <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>/*  */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/*  */</script><script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/7f7b5.js?00381' id='vr-bounce-timer-js'></script> <script type='text/javascript' src='https://ras.vistaradio.ca/dist/asyncj.php?ver=4f85c9ee8e1c0f7e86b56bef663f3bff' id='ras-loader-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/2a2e6.js?e5a31' id='jquery-effects-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/ebb2a.js?73e1f' id='jquery-effects-fade-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/bab55.js?cf6e4' id='jquery-ui-core-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/46609.js?35179' id='jquery-ui-accordion-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/70964.js?adc50' id='jquery-ui-tabs-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/a7ee8.js?34837' id='vwscjs-main-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/ffbb3.js?79832' id='vwjs-fitvids-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/c50b5.js?97eff' id='vwjs-isotope-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/65817.js?6410c' id='vwjs-flexslider-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/0ca7d.js?45455' id='vwjs-swipebox-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/7f3b6.js?cdc2f' id='vwjs-asset-js'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/main.js?ver=2.0' id='vwjs-main-js'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/custom.js?ver=4f85c9ee8e1c0f7e86b56bef663f3bff' id='child-js-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/d6ec0.js?ead68' id='wp-embed-js'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/5e8a9.js?e7213' id='promotional-carousel-js'></script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56914607-34', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');</script> <script type='text/javascript'>;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );

			})( jQuery, window , document );</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=335982600081119&version=v2.3&";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <style>.main-nav {margin-top:-25px !important;}</style></body></html>
<!-- Page optimized by LiteSpeed Cache @2021-05-24 23:36:33 -->
<!-- Page supported by LiteSpeed Cache 3.6.2 on 2021-05-24 16:36:33 -->