<!DOCTYPE html><html class="no-js" lang="en-CA"
xmlns:fb="http://ogp.me/ns/fb#"><head><meta charset="UTF-8"><title>Northern Health posts daily record 68 new COVID-19 infections, active cases province-wide plummet by 300 | My Nechako Valley Now</title><link href="//www.google-analytics.com" rel="dns-prefetch"><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta name="viewport" content="width=device-width,initial-scale=1.0,user-scalable=yes"><link rel="shortcut icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="114x114" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="72x72" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><link rel="apple-touch-icon" sizes="144x144" href="//cdn.vistaradio.ca/wp-content/themes/presso-child/vista/_img/mynow-icon.png"><meta property="og:site_name" content="My Nechako Valley Now"><meta property="og:url" content="https://www.mynechakovalleynow.com/24571/northern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr/"/><meta property="og:type" content="article" /><meta property="og:title" content="Northern Health posts daily record 68 new COVID-19 infections, active cases province-wide plummet by 300" /><meta property="og:description" content="BC Health Officials announced 582 new cases of COVID-19, boosting the provincial total 48,609 cases province-wide. Sixty-eight of those occurred in Northern ... more &#8250;"><meta property="og:image" content="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2.jpg" /><meta property="og:image:width" content="600" /><meta property="og:image:height" content="314" /> <script data-ad-client="ca-pub-3985045263764181" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <link rel="stylesheet" id="wp-forecast-css" href="https://www.mynechakovalleynow.com/wp-content/plugins/wp-forecast/wp-forecast-default.css" type="text/css" media="screen" /> <script>/* You can add more configuration options to webfontloader by previously defining the WebFontConfig with your options */
                            if ( typeof WebFontConfig === "undefined" ) {
                                WebFontConfig = new Object();
                            }
                            WebFontConfig['google'] = {families: ['Oswald:300,400,700', 'Open+Sans:300,400,600,700,800,300italic,400italic,600italic,700italic,800italic']};

                            (function() {
                                var wf = document.createElement( 'script' );
                                wf.src = 'https://ajax.googleapis.com/ajax/libs/webfont/1.5.3/webfont.js';
                                wf.type = 'text/javascript';
                                wf.async = 'true';
                                var s = document.getElementsByTagName( 'script' )[0];
                                s.parentNode.insertBefore( wf, s );
                            })();</script> <link rel='dns-prefetch' href='//ras.vistaradio.ca' /><link rel='dns-prefetch' href='//cdn.vistaradio.ca' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="My Nechako Valley Now &raquo; Feed" href="https://www.mynechakovalleynow.com/feed/" /><link rel="alternate" type="text/calendar" title="My Nechako Valley Now &raquo; iCal Feed" href="https://www.mynechakovalleynow.com/community-calendar/?ical=1" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.mynechakovalleynow.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.4"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='tribe-tooltip-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.12.10' type='text/css' media='all' /><link rel='stylesheet' id='elusive-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/elusive.min.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='font-awesome-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/vendor/codeinwp/icon-picker/css/types/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /><link rel='stylesheet' id='menu-icons-extra-css'  href='https://www.mynechakovalleynow.com/wp-content/plugins/menu-icons/css/extra.min.css?ver=0.12.5' type='text/css' media='all' /><link rel='stylesheet' id='wp-block-library-css'  href='https://www.mynechakovalleynow.com/wp-includes/css/dist/block-library/style.min.css?ver=5.4.4' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-flexslider-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/flexslider/flexslider-custom.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-social-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/social-icons/css/zocial.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-entypo-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/entypo/css/entypo.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-icon-symbol-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/font-icons/symbol/css/symbol.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-swipebox-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/swipebox/swipebox.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-bootstrap-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/framework/bootstrap/css/bootstrap.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='vwcss-theme-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso/css/theme.css?ver=2.0' type='text/css' media='all' /><link rel='stylesheet' id='child-style-css'  href='https://www.mynechakovalleynow.com/wp-content/themes/presso-child/style.css?ver=5.4.4' type='text/css' media='all' /> <script type='text/javascript' src='https://www.mynechakovalleynow.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/61e54.js?b2f26'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/396e8.js?b5021'></script> <script type='text/javascript'>/*  */
var instant_search = {"blog_url":"https:\/\/www.mynechakovalleynow.com","ajax_url":"https:\/\/www.mynechakovalleynow.com\/wp-admin\/admin-ajax.php","placeholder":"Search"};
/*  */</script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/0b9b3.js?cb358'></script> <script type='text/javascript' src='https://cdn.vistaradio.ca/js/iframeResizer.js'></script> <link rel='https://api.w.org/' href='https://www.mynechakovalleynow.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.mynechakovalleynow.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.mynechakovalleynow.com/wp-includes/wlwmanifest.xml" /><link rel='prev' title='Northern Health confirms additional COVID-19 cases related to Coastal Gas Link work sites outbreak' href='https://www.mynechakovalleynow.com/24567/northern-health-confirms-additional-covid-19-cases-related-to-coastal-gas-link-work-site-outbreak/' /><meta name="generator" content="WordPress 5.4.4" /><link rel="canonical" href="https://www.mynechakovalleynow.com/24571/northern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr/" /><link rel='shortlink' href='https://www.mynechakovalleynow.com/?p=24571' /><link rel="alternate" type="application/json+oembed" href="https://www.mynechakovalleynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.mynechakovalleynow.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F&#038;format=xml" /><meta property="fb:app_id" content="335982600081119"/><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.mynechakovalleynow.com"><link rel="https://theeventscalendar.com/" href="https://www.mynechakovalleynow.com/wp-json/tribe/events/v1/" /><style id="vw-custom-font" type="text/css"></style><style type="text/css">::selection { color: white; background-color: #3facd6; }
		
		h1 { line-height: 1.1; }
		h2 { line-height: 1.2; }
		h3, h4, h5, h6 { line-height: 1.4; }

		.header-font,
		woocommerce div.product .woocommerce-tabs ul.tabs li, .woocommerce-page div.product .woocommerce-tabs ul.tabs li, .woocommerce #content div.product .woocommerce-tabs ul.tabs li, .woocommerce-page #content div.product .woocommerce-tabs ul.tabs li
		{ font-family: Oswald; font-weight: 700; }
		.header-font-color { color: #333333; }

		.wp-caption p.wp-caption-text {
			color: #333333;
			border-bottom-color: #333333;
		}
		
		.body-font { font-family: Open Sans; font-weight: 400; }

		/* Only header font, No font-weight */
		.mobile-nav,
		.top-nav,
		.comment .author > span, .pingback .author > span, 
		.label, .tagcloud a,
		.woocommerce .product_meta .post-tags a,
		.bbp-topic-tags a,
		.woocommerce div.product span.price, .woocommerce-page div.product span.price, .woocommerce #content div.product span.price, .woocommerce-page #content div.product span.price, .woocommerce div.product p.price, .woocommerce-page div.product p.price, .woocommerce #content div.product p.price, .woocommerce-page #content div.product p.price,
		.main-nav .menu-link { font-family: Oswald; }

		/* Primary Color */
		.primary-bg,
		.label, .tagcloud a,
		.woocommerce nav.woocommerce-pagination ul li span.current, .woocommerce-page nav.woocommerce-pagination ul li span.current, .woocommerce #content nav.woocommerce-pagination ul li span.current, .woocommerce-page #content nav.woocommerce-pagination ul li span.current, .woocommerce nav.woocommerce-pagination ul li a:hover, .woocommerce-page nav.woocommerce-pagination ul li a:hover, .woocommerce #content nav.woocommerce-pagination ul li a:hover, .woocommerce-page #content nav.woocommerce-pagination ul li a:hover, .woocommerce nav.woocommerce-pagination ul li a:focus, .woocommerce-page nav.woocommerce-pagination ul li a:focus, .woocommerce #content nav.woocommerce-pagination ul li a:focus, .woocommerce-page #content nav.woocommerce-pagination ul li a:focus,
		#pagination > span {
			background-color: #3facd6;
		}
		a, .social-share a:hover, .site-social-icons a:hover,
		.bbp-topic-header a:hover,
		.bbp-forum-header a:hover,
		.bbp-reply-header a:hover { color: #3facd6; }
		.button-primary { color: #3facd6; border-color: #3facd6; }
		.primary-border { border-color: #3facd6; }

		/* Top-bar Colors */
		.top-bar {
			background-color: #333333;
			color: #eeeeee;
		}

		#open-mobile-nav, .top-nav  a, .top-bar-right > a {
			color: #eeeeee;
		}

		#open-mobile-nav:hover, .top-nav  a:hover, .top-bar-right > a:hover {
			background-color: #3facd6;
			color: #ffffff;
		}

		.top-nav .menu-item:hover { background-color: #3facd6; }
		.top-nav .menu-item:hover > a { color: #ffffff; }

		/* Header Colors */
		.main-bar {
			background-color: #f9f9f9;
			color: #bbbbbb;
		}

		/* Main Navigation Colors */
		.main-nav-bar {
			background-color: #333333;
		}

		.main-nav-bar, .main-nav > .menu-item > a {
			color: #ffffff;
		}

		.main-nav .menu-item:hover > .menu-link,
		.main-nav > .current-menu-ancestor > a,
		.main-nav > .current-menu-item > a {
			background-color: #3facd6;
			color: #ffffff;
		}

		/* Widgets */
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-icon { background-color: #3facd6; }
		.widget_vw_widget_social_subscription .social-subscription:hover .social-subscription-count { color: #3facd6; }

		.widget_vw_widget_categories a:hover { color: #3facd6; }

		/* Footer Colors */
		#footer {
			background-color: #111111;
		}

		#footer .widget-title {
			color: #3facd6;
		}

		#footer,
		#footer .title,
		#footer .comment-author,
		#footer .social-subscription-count
		{ color: #999999; }

		.copyright {
			background-color: #000000;
		}
		.copyright, .copyright a {
			color: #dddddd;
		}

		/* Custom Styles */</style><style type="text/css" title="dynamic-css" class="options-output">h1, h2, h3, h4, h5, h6{font-family:Oswald;text-transform:uppercase;font-weight:700;font-style:700;color:#333333;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading h1, h2, h3, h4, h5, h6,{opacity: 0;}.ie.wf-loading h1, h2, h3, h4, h5, h6,{visibility: hidden;}body{font-family:"Open Sans";font-weight:400;font-style:400;color:#666666;font-size:14px;opacity: 1;visibility: visible;-webkit-transition: opacity 0.24s ease-in-out;-moz-transition: opacity 0.24s ease-in-out;transition: opacity 0.24s ease-in-out;}.wf-loading body,{opacity: 0;}.ie.wf-loading body,{visibility: hidden;}</style>
<!--[if lt IE 9]> <script src="//cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7/html5shiv.min.js"></script> <script src="//cdnjs.cloudflare.com/ajax/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--> <script data-optimized="1" type="text/javascript" src="https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/28033.js?0fbfd"></script> <script type="text/javascript">jQuery(document).ready(function() {
				jQuery('body').ihavecookies({
						title: 'Accept Cookies & Privacy Policy?',
						message: 'We use technologies, such as cookies, to customise content and advertising, to provide social media features and to analyse traffic to the site. By continuing to use our website you consent to our Cookie and Privacy Policy. ',
						delay: 600,
						expires: 1825,
						link: 'https://www.vistaradio.ca/privacy/',
						//onAccept: function(){
						//		alert('Yay! You clicked the accept button. This is an optional callback function that can be set on accept.');
						//},
						uncheckBoxes: true
				});
		});</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans" rel="stylesheet"><style type="text/css">:root {
				--purple: #3B3646;
				--red: #EE4B5A;
		}
		/* Cookie Dialog */
		#gdpr-cookie-message {
				position: fixed;
				right: 30px;
				bottom: 30px;
				max-width: 375px;
				background-color: var(--purple);
				padding: 20px;
				border-radius: 5px;
				box-shadow: 0 6px 6px rgba(0,0,0,0.25);
				margin-left: 30px;
				font-family: system-ui;
		}
		#gdpr-cookie-message h4 {
				color: var(--red);
				font-family: 'Open Sans', sans-serif;
				font-size: 18px;
				font-weight: 500;
				margin: 0 0 10px;
		}
		#gdpr-cookie-message p {
				color: white;
				font-size: 15px;
				line-height: 1.5em;
		}
		#gdpr-cookie-message p:last-child {
				margin-bottom: 0;
				text-align: right;
		}
		#gdpr-cookie-message a {
				color: var(--red);
				text-decoration: none;
				font-size: 15px;
				padding-bottom: 2px;
				border-bottom: 1px dotted rgba(255,255,255,0.75);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message a:hover {
				color: white;
				border-bottom-color: var(--red);
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button {
				border: none;
				background: var(--red);
				color: white;
				font-family: 'Open Sans', sans-serif;
				font-size: 15px;
				padding: 7px;
				border-radius: 3px;
				margin-left: 15px;
				cursor: pointer;
				transition: all 0.3s ease-in;
		}
		#gdpr-cookie-message button:hover {
				background: white;
				color: var(--red);
				transition: all 0.3s ease-in;
		}</style></head><body id="top" class="post-template-default single single-post postid-24571 single-format-standard custom-background tribe-no-js tribe-theme-parent-presso tribe-theme-child-presso-child site-layout-boxed site-disable-post-box-effects"><nav id="mobile-nav-wrapper"></nav><aside class="zone takeover"><ins data-revive-zoneid="118" data-revive-target="_blank" data-revive-id="b07d3d41c82582579069d81820142439"></ins></aside><div style="position: fixed; top:0px; left:0px; z-index: -1; background: url(//ras.vistaradio.ca/dist/avw.php?raszid=247) center top no-repeat; background-size: cover; width: 100%; height:100%;"><a href="//ras.vistaradio.ca/dist/ck.php?n=NID&amp;cb=RANDOM_NUMBER" target="_blank" style="display: block; width: 100%; height: 100%;"></a></div><div id="off-canvas-body-inner"><div id="top-bar" class="top-bar"><div class="container"><div class="row"><div class="col-sm-12">
<span id="weather-ajax"></span><div class="weather-zone"><script data-optimized="1" src= "/bmp-zone-weather.js?v=20201203"></script></div> <script>jQuery.ajax({
		url : "/wp-content/themes/presso-child/vista/weather-ajax.php",
		dataType: "text",
		success : function (data) {
			if (data!="") {
				jQuery("#weather-ajax").html(data);
			}
		}
	});</script> <div id="listen-live-header"><div class="listen-live-station listen-live-link" data-stream="civh" id="hdr-ll-civh"><div class="wrapper"><span><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/icons/play-hdr.png" alt="Listen Live to 95.9 the GOAT"></span>
<span><h3 class="brand-goat">95.9 the GOAT</h3><h4><div class="song-ticker"></div></h4>
</span></div></div> <script>(function($){
    $('document').ready(function() {
        $.ajax({
            url : "/wp-content/themes/presso-child/nowplaying.php?s=CIVH&g=ROCK&l=1&nolist=true&ts="+ Date.now() +"",
               dataType: "text",
               cache: false,
               success : function (data) {
                if (data) {
                    $("#hdr-ll-civh .song-ticker").html(data);
                    $(".time").css('display','none');

                    if ($('#hdr-ll-civh p.artist').textWidth() + $('#hdr-ll-civh .title').textWidth() >= '90') {
                        $('#hdr-ll-civh .song-ticker').addClass('marquee');
                    }
                    //if ($('#hdr-ll-civh .title').textWidth() >= '80') {
                    //  $('#hdr-ll-civh .title').addClass('marquee');
                    //}

                }
            }
        });
    });
})(jQuery);</script> </div></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav"><i class="icon-entypo-menu">menu</i></a>
<a id="open-mobile-nav" class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div></div><div class="row"><div class="col-sm-12">
<a id="open-mobile-nav" href="#mobile-nav" title="Search"></a></div></div></div></div><header class="main-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div id="logo" class="" style="/*display: block; text-align: center; margin-bottom: 1em; width: 100%;*/">
<a href="https://www.mynechakovalleynow.com/" style="white-space: nowrap;">
<span id="mynow-icon"><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/mynow-icon.png" alt="My Nechacko Now" border="0" width="63" height="63" class="logo-original" /></span>
<span id="mynow-logo"><img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/comm/mynechakovalleynow.png" alt="My Nechacko Now" border="0" width="100%" height="50" class="logo-original" /></span>
</a></div><div id="station-logo-header" style="/*display: block; text-align: center; width: 100%;*/"><div>
<a href="https://www.mynechakovalleynow.com/95-9-the-goat/">
<img src="https://www.mynechakovalleynow.com/wp-content/themes/presso-child/vista/_img/station/CIVH.png?201022" alt="95.9 the GOAT" width="" height="" border="0" class="brand-goat" />
</a></div></div></div></div></div></header><div class="main-nav-bar header-layout-left-logo"><div class="container"><div class="row"><div class="col-sm-12"><div class="top-bar-right">
<a class="site-social-icon" href="https://www.facebook.com/Valley-Country-165380483533130/" title="Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="site-social-icon" href="https://twitter.com/ValleyCountryAM" title="Twitter" target="_blank"><i class="icon-social-twitter"></i></a>									<a class="instant-search-icon" href="#menu1"><i class="icon-entypo-search"></i></a></div><nav id="main-nav-wrapper"><ul id="menu-main-navigation" class="main-nav list-unstyled"><li id="nav-menu-item-53" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children"><a href="https://www.mynechakovalleynow.com/category/news/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-bullhorn" aria-hidden="true"></i><span>News</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-55" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent"><a href="https://www.mynechakovalleynow.com/category/news/" class="menu-link sub-menu-link"><span>News</span></a></li><li id="nav-menu-item-201" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/category/news/nechako-valley/" class="menu-link sub-menu-link"><span>Nechako Valley</span></a></li><li id="nav-menu-item-202" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/category/news/provincial/" class="menu-link sub-menu-link"><span>Provincial</span></a></li><li id="nav-menu-item-14025" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/hartleys-cat-scan/" class="menu-link sub-menu-link"><span><i class="_mi _before fa fa-podcast" aria-hidden="true"></i><span>Hartley&#8217;s Cat Scan Podcast</span></span></a></li><li id="nav-menu-item-56" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/submit-news-tip/" class="menu-link sub-menu-link"><span>Submit News Tip</span></a></li></ul></li><li id="nav-menu-item-2222" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/category/win/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-smiley" aria-hidden="true"></i><span>Win</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-52" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children"><a href="/community-calendar/" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-calendar" aria-hidden="true"></i><span>Events</span></span></a><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-360" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/" class="menu-link sub-menu-link"><span>View Calendar</span></a></li><li id="nav-menu-item-359" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-custom menu-item-object-custom"><a href="/community-calendar/community/add" class="menu-link sub-menu-link"><span>Submit Event</span></a></li></ul></li><li id="nav-menu-item-63" class="main-menu-item  menu-item-even menu-item-depth-0 nav-listen-live-link menu-item menu-item-type-custom menu-item-object-custom"><a rel="civh" href="#" class="menu-link main-menu-link"><span><i class="_mi _before elusive el-icon-play-alt" aria-hidden="true"></i><span>Listen Live</span></span></a></li><li id="nav-menu-item-2342" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item-on-air menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children"><a href="https://www.mynechakovalleynow.com/category/on-air/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-microphone" aria-hidden="true"></i><span>On Air</span></span></a><div class="sub-menu-container"><ul class="sub-menu menu-odd  menu-depth-1"><li id="nav-menu-item-2343" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/category/on-air/" class="menu-link sub-menu-link"><span>Shows &#038; More</span></a></li><li id="nav-menu-item-2341" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/95-9-the-goat/" class="menu-link sub-menu-link"><span>Talent</span></a></li><li id="nav-menu-item-2340" class="sub-menu-item  menu-item-odd menu-item-depth-1 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/contact-us/" class="menu-link sub-menu-link"><span>Contact Us</span></a></li></ul></li><li id="nav-menu-item-13972" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-taxonomy menu-item-object-category"><a href="https://www.mynechakovalleynow.com/category/local-connections/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-star" aria-hidden="true"></i><span>Local Connections</span></span></a><div class="sub-menu-container"></li><li id="nav-menu-item-14026" class="main-menu-item  menu-item-even menu-item-depth-0 menu-item menu-item-type-post_type menu-item-object-page"><a href="https://www.mynechakovalleynow.com/hartleys-cat-scan/" class="menu-link main-menu-link"><span><i class="_mi _before fa fa-podcast" aria-hidden="true"></i><span>Podcast</span></span></a></li></ul></nav></div></div></div></div><div id="page-wrapper" class="container"><div class="row"><div id="page-content" class="col-sm-7 col-md-8"><article id="post-24571" class="post-24571 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="tags clearfix">
<a class="label " href="https://www.mynechakovalleynow.com/category/news/" title="View all posts in News" rel="category">News</a></div><h1 class="post-title title title-large entry-title">Northern Health posts daily record 68 new COVID-19 infections, active cases province-wide plummet by 300</h1><hr class="hr-thin-bottom"><div class="social-share">
<span class="header-font">SHARE ON:</span><a class="social-facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F&amp;t=http://Northern%20Health%20posts%20daily%20record%2068%20new%20COVID-19%20infections,%20active%20cases%20province-wide%20plummet%20by%20300" title="Share on Facebook" target="_blank"><i class="icon-social-facebook"></i></a><a class="social-twitter" href="https://twitter.com/share?text=Northern+Health+posts+daily+record+68+new+COVID-19+infections%2C+active+cases+province-wide+plummet+by+300&url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F" title="Share on Twitter" target="_blank"><i class="icon-social-twitter"></i></a><a class="social-googleplus" href="https://plus.google.com/share?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F" title="Share on Google+" target="_blank"><i class="icon-social-gplus"></i></a><a class="social-pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.mynechakovalleynow.com%2F24571%2Fnorthern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr%2F&amp;media=https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2.jpg&amp;description=http://Northern%20Health%20posts%20daily%20record%2068%20new%20COVID-19%20infections,%20active%20cases%20province-wide%20plummet%20by%20300" title="Share on Pinterest" target="_blank"><i class="icon-social-pinterest"></i></a></div><div class="post-meta header-font">
<img src="https://www.mynechakovalleynow.com/wp-content/litespeed/avatar/663afa9538f7fbd1cc787cb9152c6149.jpg" width="48" height="48" alt="Avatar" class="avatar avatar-48 wp-user-avatar wp-user-avatar-48 photo avatar-default" />			<a class="author-name vcard author" href="https://www.mynechakovalleynow.com/talent/brendan/" title="View all posts by Brendan Pawliw"><span class="fn">Brendan Pawliw</span></a><span class="post-meta-separator">,</span>
<span class="label-staff">staff</span><span class="post-meta-separator"></span>
<a href="https://www.mynechakovalleynow.com/24571/northern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr/" class="post-date updated" title="Permalink to Northern Health posts daily record 68 new COVID-19 infections, active cases province-wide plummet by 300" rel="bookmark">Thursday Dec. 24th, 2020</a></div><div class="post-thumbnail-wrapper">
<a class="swipebox" href="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2.jpg" title="Permalink to image of Northern Health posts daily record 68 new COVID-19 infections, active cases province-wide plummet by 300" rel="bookmark">
<img width="750" height="420" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2-750x420.jpg" class="attachment-vw_medium size-vw_medium wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2.jpg 750w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2-300x168.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/50265258046_dbea70b716_c-750x420-2-265x147.jpg 265w" sizes="(max-width: 750px) 100vw, 750px" />
</a><div class="vw-featured-image-caption-wrapper"><div class="vw-featured-image-caption">
<i class="icon-entypo-camera"></i> Dr.Bonnie Henry (photo by BC Government Flickr)</div></div></div><div class="post-content clearfix"><p>BC Health Officials announced 582 new cases of COVID-19, boosting the provincial total 48,609 cases province-wide.</p><p>Sixty-eight of those occurred in Northern Health raising the region&#8217;s total to 1,719, which is a new single-day record smashing the old mark of 50 set back <a href="https://www.myprincegeorgenow.com/132756/northern-health-sees-50-new-infections-of-covid-19-bc-records-another-11-deaths/">on December 4th</a>.</p><p>Of those, 516 are considered active with 50 people currently hospitalized, 16 of whom are in ICU.</p><p>Across the province, 341 people remain in hospital, 78 of which are in critical care.</p><p>Currently, 9,732 people are under active public health monitoring while 37,784 residents have recovered, bringing our recovery rate to nearly 78%.</p><p>However, 12 new deaths occurred making the death toll 808 with the north claiming 21 of those.</p><p>On a positive note, the number of active cases decreased by 308 today (Thursday) bringing the total to 8,865 &#8211; Wednesday’s mark was 9,137.</p><p>&#8220;This Christmas and over the holiday weekend is the time to try the many new virtual activities that have been arranged this year &#8211; whether a church service, holiday choral concert or theatre performance,&#8221; said Dr. Bonnie Henry.</p><p>&#8220;Take a walk with those in your household and spread some cheer with neighborhood carolling, or drop off a warm meal or holiday treats to someone who may be away from their family this year.</p><p>In addition, 26-hundred more people have received the Pfizer-BioNTech vaccine in the past day, upping the total number of immunizations to 8,178.</p><p>&#8220;We can all safely connect with loved ones near and far &#8211; those in our community, in different parts of the province and around the world with the many tools available to us.&#8221;</p><p>&#8220;By staying small and staying apart this holiday season, we&#8217;re protecting the people we care about most and ensuring the coming weeks and months are better, brighter and safer for everyone. Together, let&#8217;s make this holiday season a safe season for all of us,&#8221; added Henry.</p><p><a href="https://experience.arcgis.com/experience/a6f23959a8b14bfa989e3cda29297ded" target="_blank" rel="noopener noreferrer">Breakdown by region:</a></p><p>North: + 68 (1,720)<br />
Interior: + 71 (3,511)<br />
Vancouver Coastal: + 107 (11,535)<br />
Fraser : + 326 (30,875)<br />
Island: + 10 (857)</p><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="fb-comments-box"><div class="fb-comments" data-href="https://www.mynechakovalleynow.com/24571/northern-health-posts-record-high-68-new-covid-infections-active-cases-province-wide-plummet-by-300corr/" data-num-posts="5" data-width="100%" data-colorscheme="light"></div></div></div></article><hr class="hr-thin-bottom"><div class="z1"><script data-optimized="1" src= "/bmp-zone1.js"></script></div><div class="post-related section-container clearfix"><h2 class="section-title">Recent Posts</h2><div class="row"><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-24567 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/24567/northern-health-confirms-additional-covid-19-cases-related-to-coastal-gas-link-work-site-outbreak/" title="Permalink to Northern Health confirms additional COVID-19 cases related to Coastal Gas Link work sites outbreak" rel="bookmark">Northern Health confirms additional COVID-19 cases related to Coastal Gas Link work sites outbreak</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/24567/northern-health-confirms-additional-covid-19-cases-related-to-coastal-gas-link-work-site-outbreak/" class="post-date" title="Permalink to Northern Health confirms additional COVID-19 cases related to Coastal Gas Link work sites outbreak" rel="bookmark">Thursday Dec. 24th, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/24567/northern-health-confirms-additional-covid-19-cases-related-to-coastal-gas-link-work-site-outbreak/" title="Permalink to Northern Health confirms additional COVID-19 cases related to Coastal Gas Link work sites outbreak" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Northern-Health-logo-750x420-1-7-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Northern-Health-logo-750x420-1-7-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Northern-Health-logo-750x420-1-7-300x168.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Northern-Health-logo-750x420-1-7-360x200.jpg 360w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Northern-Health-logo-750x420-1-7.jpg 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 "><article class="post-24564 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/24564/death-toll-from-jubilee-lodge-outbreak-increases-to-seven/" title="Permalink to Death toll from Jubilee Lodge outbreak increases to seven" rel="bookmark">Death toll from Jubilee Lodge outbreak increases to seven</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/24564/death-toll-from-jubilee-lodge-outbreak-increases-to-seven/" class="post-date" title="Permalink to Death toll from Jubilee Lodge outbreak increases to seven" rel="bookmark">Thursday Dec. 24th, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/24564/death-toll-from-jubilee-lodge-outbreak-increases-to-seven/" title="Permalink to Death toll from Jubilee Lodge outbreak increases to seven" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Capture-750x420-2-265x147.png" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Capture-750x420-2-265x147.png 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Capture-750x420-2-300x168.png 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Capture-750x420-2-360x200.png 360w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/Capture-750x420-2.png 750w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div><div class="post-box-wrapper col-sm-6 col-md-4 hidden-sm"><article class="post-24561 post-box post-box-headline"><h3 class="title title-small"><a href="https://www.mynechakovalleynow.com/24561/its-definitely-a-strain-nh-respiratory-therapist-talks-demanding-workload-during-second-wave/" title="Permalink to “It’s definitely a strain,”: NH Respiratory Therapist talks demanding workload during second wave" rel="bookmark">“It’s definitely a strain,”: NH Respiratory Therapist talks demanding workload during second wave</a></h3><div class="post-meta header-font">
<a href="https://www.mynechakovalleynow.com/24561/its-definitely-a-strain-nh-respiratory-therapist-talks-demanding-workload-during-second-wave/" class="post-date" title="Permalink to “It’s definitely a strain,”: NH Respiratory Therapist talks demanding workload during second wave" rel="bookmark">Thursday Dec. 24th, 2020</a></div><div class="post-thumbnail-wrapper vw-imgliquid">
<a href="https://www.mynechakovalleynow.com/24561/its-definitely-a-strain-nh-respiratory-therapist-talks-demanding-workload-during-second-wave/" title="Permalink to “It’s definitely a strain,”: NH Respiratory Therapist talks demanding workload during second wave" rel="bookmark">
<img width="265" height="147" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/richelle-maser-506x420-1-265x147.jpg" class="attachment-vw_small_2 size-vw_small_2 wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/richelle-maser-506x420-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/12/richelle-maser-506x420-1-360x200.jpg 360w" sizes="(max-width: 265px) 100vw, 265px" />			</a></div></article></div></div></div></div><aside id="page-sidebar" class="sidebar-wrapper col-sm-5 col-md-4"><div class="sidebar-inner"><div id="text-17" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div><div id="vw_widget_post_slider-4" class="widget vw-sidebar-blog widget_vw_widget_post_slider"><h3 class="widget-title"><span class="super-title">Sponsored Articles</span>Local Connections</h3><div class="post-box-list"><div class="flexslider no-control-nav post-slider"><ul class="slides"><li>
<a href="https://www.mynechakovalleynow.com/24142/plan-your-next-adventure-right-here-in-prince-george/" title="Permalink to Plan Your Next Adventure Right Here in Prince George" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Tourism-PG-November-Staycation-LC-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Plan Your Next Adventure Right Here in Prince George</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/24074/northern-health-flu-clinics-are-now-running/" title="Permalink to Northern Health Flu Clinics are Now Running" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/11/Northern-Health-Flu-Season-LC-810x450-1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Northern Health Flu Clinics are Now Running</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/23535/basecamp-to-the-north/" title="Permalink to Basecamp to the North" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/09/Tourism-Prince-George-New-Branding-LC-Article-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Basecamp to the North</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/23035/exploring-the-best-of-adult-living-in-prince-george/" title="Permalink to Exploring the Best of Adult Living in Prince George" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/08/New-Rock-Developments-August-LC-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Exploring the Best of Adult Living in Prince George</span></h3></div>
</a></li><li>
<a href="https://www.mynechakovalleynow.com/22710/phase-4-at-ridgewood-landing/" title="Permalink to Phase 4 at Ridgewood Landing" rel="bookmark"><div class="post-thumbnail-wrapper">
<img width="810" height="450" src="https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1.jpg" class="attachment-vw_large size-vw_large wp-post-image" alt="" srcset="https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1.jpg 810w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1-300x167.jpg 300w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1-768x427.jpg 768w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1-265x147.jpg 265w, https://www.mynechakovalleynow.com/wp-content/uploads/2020/06/New-Rock-Developments-July-LC-810x450-R1-360x200.jpg 360w" sizes="(max-width: 810px) 100vw, 810px" /></div><div class=""><h3 class="title">
<span>Phase 4 at Ridgewood Landing</span></h3></div>
</a></li></ul></div></div></div><div id="text-18" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-side v-promotional-carousel"><div class="v-side v-promotional"><ol><li><img src="https://www.mynechakovalleynow.com/wp-content/plugins/vista-addons/img/facebook-contest-like-300x90.gif"></li></ol></div></div></div></div><div id="text-19" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div><div id="text-20" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="v-tall-side v-promotional-carousel"><div class="v-tall-side v-promotional"><ol><li><a target="_blank" data-stream="civh" class="listen-live-link" rel="noopener noreferrer"><img src="https://www.mynechakovalleynow.com/wp-content/plugins/vista-addons/img/never-miss-a-beat-300-525-goat.jpg" width="300" height="525"></a></li></ol></div></div></div></div><div id="text-21" class="widget vw-sidebar-blog widget_text"><div class="textwidget"><div class="z2 va-side"><script data-optimized="1" src= "/bmp-zone2.js"></script></div></div></div></div></aside></div></div><footer id="footer"><div id="footer-nav"><div class="container"><div class="row"><div class="col-sm-5"><div class="v-footer-menu"><ul id="menu-footer" class="menu"><li id="menu-item-67" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-67"><a href="https://www.mynechakovalleynow.com/category/news/">News</a></li><li id="menu-item-2220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2220"><a href="https://www.mynechakovalleynow.com/category/win/">Win</a></li><li id="menu-item-66" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-66"><a href="/community-calendar/">Events</a></li><li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-70"><a href="https://www.mynechakovalleynow.com/contact-us/">Contact Us</a></li><li id="menu-item-69" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69"><a href="https://www.mynechakovalleynow.com/advertise-us/">Advertise</a></li><li id="menu-item-2221" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2221"><a href="http://www.vistaradio.ca/about/working-at-vista/">Careers</a></li></ul></div><div class="v-policy-menu"><ul id="menu-policy-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/privacy" target="_blank">Privacy Policy</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom"><a href="https://www.vistaradio.ca/terms-of-service/" target="_blank">Terms Of Service</a></li></ul></div></div></div></div></div><div class="copyright"><div class="container"><div class="row"><div class="col-sm-6 copyright-left">
<a href="http://www.vistaradio.ca" target="_blank"><img src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/vista-logo-footer.png" width="86" height="30" border="0" alt="Powered by Vista Radio" /></a></div><div class="col-sm-6 copyright-right"><a href="http://radioplayer.vistaradio.ca" target="_blank"><img width="107" height="30" style="width:107px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/rpc-logo-w30.png"></a>
&nbsp;
<a href="https://itunes.apple.com/ca/app/radioplayer-canada/id1204742241" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-itunes1.png"></a>
&nbsp;
<a href="https://play.google.com/store/apps/details?id=ca.radioplayer.android" target="_blank"><img width="101" height="30" style="width:101px;height:30px" src="//cdn.vistaradio.ca/wp-content/themes/presso-child/images/get-on-play1.png"></a></div></div></div></div></footer></div>  <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>/*  */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/*  */</script><script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/7f7b5.js?b12df'></script> <script type='text/javascript' src='https://ras.vistaradio.ca/dist/asyncj.php?ver=5.4.4'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/2a2e6.js?303a8'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/ebb2a.js?08495'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/bab55.js?6727f'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/f5f8a.js?06571'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/46609.js?d14aa'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/70964.js?61c06'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/a7ee8.js?8131d'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/ffbb3.js?0cb1e'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/c50b5.js?1180e'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/65817.js?1c58e'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/0ca7d.js?8e8c8'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/7f3b6.js?20831'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/main.js?ver=2.0'></script> <script type='text/javascript' src='//cdn.vistaradio.ca/wp-content/themes/presso-child/js/custom.js?ver=5.4.4'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/d6ec0.js?71185'></script> <script data-optimized="1" type='text/javascript' src='https://www.mynechakovalleynow.com/wp-content/litespeed/cssjs/5e8a9.js?0a8c6'></script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-56914607-34', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');</script> <script type='text/javascript'>;(function( $, window, document, undefined ){
				"use strict";

				$( document ).ready( function ($) {
							$( '.flexslider' ).flexslider({
			animation: "fade",
			easing: "easeInCirc",
			slideshow: true,
			slideshowSpeed: 4000,
			animationSpeed: 600,
			randomize: false,
			pauseOnHover: true,
			prevText: '',
			nextText: '',
			start: function( slider ) {
				slider.css( 'opacity', '1' );
				slider.find( '.post-thumbnail-wrapper' ).css( 'height', '500px' ).imgLiquid().fadeIn(250);
			},
		});
					} );

			})( jQuery, window , document );</script> <div id="fb-root"></div> <script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=335982600081119&version=v2.3&";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script> <style>.main-nav {margin-top:-25px !important;}</style></body></html>
<!-- Page optimized by LiteSpeed Cache @2020-12-25 10:08:07 -->
<!-- Page supported by LiteSpeed Cache 3.6 on 2020-12-25 02:08:07 -->